declare compatibility with 3.5