declare compatibility with 4.0.*