upgrade build environment and libraries
authorDamyan Ivanov <dam+mobileledger@ktnx.net>
Tue, 9 Jun 2020 19:32:13 +0000 (19:32 +0000)
committerDamyan Ivanov <dam+mobileledger@ktnx.net>
Tue, 9 Jun 2020 19:32:13 +0000 (19:32 +0000)
app/build.gradle
build.gradle
gradle/wrapper/gradle-wrapper.properties

index 4385164..f5b092c 100644 (file)
@@ -39,32 +39,32 @@ android {
         }
     }
     sourceSets { main { assets.srcDirs = ['src/main/assets', 'src/main/assets/'] } }
-    buildToolsVersion '28.0.3'
+    buildToolsVersion '29.0.3'
     compileOptions {
         sourceCompatibility JavaVersion.VERSION_1_8
         targetCompatibility JavaVersion.VERSION_1_8
     }
     productFlavors {
     }
-    viewBinding.enabled = true
+    buildFeatures.viewBinding = true
 }
 
 dependencies {
-    def nav_version = '2.3.0-alpha06'
+    def nav_version = '2.3.0-beta01'
     implementation fileTree(include: ['*.jar'], dir: 'libs')
     implementation 'androidx.legacy:legacy-support-v4:1.0.0'
-    implementation 'com.google.android.material:material:1.2.0-alpha06'
+    implementation 'com.google.android.material:material:1.3.0-alpha01'
     implementation 'androidx.constraintlayout:constraintlayout:1.1.3'
     implementation 'androidx.lifecycle:lifecycle-extensions:2.2.0'
     implementation 'androidx.recyclerview:recyclerview:1.1.0'
     testImplementation 'junit:junit:4.13'
-    androidTestImplementation 'androidx.test:runner:1.3.0-beta01'
-    androidTestImplementation 'androidx.test.espresso:espresso-core:3.3.0-beta01'
+    androidTestImplementation 'androidx.test:runner:1.3.0-rc01'
+    androidTestImplementation 'androidx.test.espresso:espresso-core:3.3.0-rc01'
     implementation 'org.jetbrains:annotations:15.0'
     implementation 'com.fasterxml.jackson.module:jackson-modules-java8:2.11.0'
     implementation "androidx.navigation:navigation-fragment:$nav_version"
     implementation "androidx.navigation:navigation-ui:$nav_version"
-    implementation 'androidx.appcompat:appcompat:1.2.0-beta01'
+    implementation 'androidx.appcompat:appcompat:1.3.0-alpha01'
 }
 
 allprojects {
index ba600f4..24248a8 100644 (file)
@@ -24,7 +24,7 @@ buildscript {
         jcenter()
     }
     dependencies {
-        classpath 'com.android.tools.build:gradle:3.6.3'
+        classpath 'com.android.tools.build:gradle:4.0.0'
         
 
         // NOTE: Do not place your application dependencies here; they belong
index 1cf7ec7..c3af6bc 100644 (file)
@@ -1,6 +1,6 @@
-#Sat Mar 14 18:00:21 EET 2020
+#Mon Jun 08 21:33:09 EEST 2020
 distributionBase=GRADLE_USER_HOME
 distributionPath=wrapper/dists
 zipStoreBase=GRADLE_USER_HOME
 zipStorePath=wrapper/dists
-distributionUrl=https\://services.gradle.org/distributions/gradle-5.6.4-all.zip
+distributionUrl=https\://services.gradle.org/distributions/gradle-6.1.1-all.zip